[jp] Jpilot's KeyRing Plugin password fails on 64-bit Ubuntu, worked on prior ver

Edward Comer ecomer at yahoo.com
Mon Sep 7 18:27:21 EDT 2009


				
				Jpilot's KeyRing Plugin password fail on 64-bit Ubuntu
			
			
			
		


		
		
		I
have previously used Jpilot's KeyRing Plugin successfully with a 32-bit
install of 8.10 Ubuntu. I am now using a 64-bit 9.04 Ubuntu and I have
a problem. The Jpilot sync and load of address, calendar, etc., all
work fine. KeyRing's database file ~/.jpilot/Keys-Gtkr.pdb is properly
backed up from the Palm (Sony PEG-SJ22/U). When I run the KeyRing
Plugin, it prompts for the KeyRing password but the password always
fails. With my previous 32-bit 8.10 Ubunto load it worked fine. Also,
when I run the java Keyring Editor, it has no problem with the same
password on the same Keys-Gtkr.pdb. Nothing has changed on the Palm
(Keyring 2.0-pre6). I have tried this with the official jpilot 1.6.0 in
the Ubuntu repository AND I compiled/installed the latest 1.6.2
directly from jpilot. Both behave the same, namely jpilot works but the
KeyRing plugin fail the password verification.



I am wondering is this a problem with the 64-bit jpilot plugin or a library issue, or a 9.04 issue.



The jpilot.log file doesn't help much:

...

jp_pref_write_rc_file()

KeyRing: plugin gui started, unique_id=0

KeyRing: stat: /home/celem/.jpilot/Keys-Gtkr.pdb

KeyRing: verify_pasword

KeyRing: stat: /home/celem/.jpilot/Keys-Gtkr.pdb

Entering jp_read_DB_files: Keys-Gtkr

Leaving jp_read_DB_files

x=5, y=45

jp_pref_write_rc_file()

...



Has anyone else experienced this problem?



 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.jpilot.org/pipermail/jpilot_lists.jpilot.org/attachments/20090907/90f25c07/attachment-0001.html>


More information about the Jpilot mailing list