[jp] jpilot password no longer working

Terry Traub terryt at terrytraub.org
Mon Sep 8 20:50:36 EDT 2008


My security password works on my T3, but ever since upgrading Jpilot to 1.6.0
it does not let me unlock private records.  Control-Z brings up "Enter PalmOS
Password:" dialog but it will not take the password.  The password continues to
work correctly on the handheld.

Date compiled Aug 26 2008 09:01:39
Compiled with these options:
  Installed Path - /usr/local
  pilot-link version - 0.12.3
  USB support - yes
  Private record support - yes
  Datebk support - yes
  Plugin support - yes
  Manana support - yes
  NLS support (foreign languages) - yes
  GTK2 support - yes

I tried unassigning the password on the handheld as per a previous discussion
on this list, but Jpilot still would not take an empty response or anything
else.

I tried renaming my .jpilot directory and doing a reinstall from the handheld,
which resulted in flakey behavior--it only restored the calendar, and it
screwed up the categories on my handheld (luckily I had just run BackupMan).

All this is suggesting to me--my databases are pretty old and I'm wondering if
I should do a clean import from CSV files or something, to give Jpilot a fresh
start.  I don't really want to do this, because it's a lot of work to get
things back the way I like them and I'm strapped for time right now.

Or is there a known problem with this version of Jpilot or pilot-link?

Also, I notice that this version of Jpilot supports Memos for Palmos > 5.2.  My
T3 runs 5.2.1 so is that compatible?  When I set it to Memos, all my memos
disappeared from Jpilot.  When I reset it back to Memo (Palmos < 5.2.1) the
memos reappeared.


Thanks for any help!
Terry



More information about the Jpilot mailing list