[jp] jpilot-sync, udev and hotplug

Jonathan Murray jmurray at whoi.edu
Fri Mar 7 11:50:59 EST 2008


David A. Desrosiers wrote:
> On Wed, 2008-03-05 at 18:27 -0500, Jonathan Murray wrote:
>> I am struggling with this same issue. When I hit the sync button on
>> the  pilot, udev makes these:
>>
>>  > usbdev2.15_ep00
>>  > usbdev2.15_ep01
>>  > usbdev2.15_ep02
>>  > usbdev2.15_ep81
>>  > usbdev2.15_ep82
>>
>> I have no idea which one to point the pilot at.
> 
> The quick answer: None of them. 
> 
> When using the kernel 'visor' module, you should always and only point
> your device to /dev/pilot, assuming your distribution provides proper,
> sane defaults and is configured correctly for udev. 
> 
> If you're only seeing the canonical device names above, and not the
> ttyUSBxx device names or a /dev/pilot symlink to these device names,
> then something is wrong and needs to be corrected on your system.
> 
> I run Ubuntu Gutsy and Hardy Heron on my development laptop and I know
> that it is set up correctly there, although I use libusb now instead of
> the standard kernel 'visor' driver. 
> 
> Did you verify that everything is configured properly, after reading my
> detailed HOWTO document on this? You should be able to find that here: 
> 
> http://www.pilot-link.org/README.usb 
> 
Thank you for the information, the README.usb was helpful.

I noticed that on my system, Ubuntu "Gutsy", when I did an lsmod, 
neither visor or usbserial were loaded.

I loaded them manually and it worked.

I added them to /etc/modules so they would return on reboot:

# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.

fuse
lp
visor
usbserial

I did not have to add anything to /etc/udev/rules.d

It appears that udev does its magic from 60-symlinks.rules:

<--snip-->

# Create /dev/pilot symlink for Palm Pilots
KERNEL=="ttyUSB*", ATTRS{product}=="Palm Handheld*|Handspring *|palmOne 
Handheld
", \
                                         SYMLINK+="pilot"

and also 60-libpisock.rules. But I don't quite understand it.
That said, it's enough to get my Clie working.

Just for fun, I took at look at what was going on in /dev when I hit 
sync on the clie:

root at boxcutter:/dev#  watch -d ls -l

This link gets added:

lrwxrwxrwx 1 root   root           7 2008-03-07 11:45 pilot -> ttyUSB1

When it disconnects,the link really does go away. This somehow amazes me.

Thanks for your help.
-- 
Jonathan Murray
linux generalist
Woods Hole Oceanographic Institution




More information about the Jpilot mailing list