[jp] jpilot-sync, udev and hotplug

Jonathan Murray jmurray at whoi.edu
Wed Mar 5 18:27:34 EST 2008


Bill Moseley wrote:
> I'm moving my jpilot setup from Debian to a Ubuntu Gutsy machine.
> I used hotplug on the Debian machine.
> 
> I'm a bit confused about how to configure on the new machine.
> For one thing, I'm not clear if I still need to use hotplug or if udev
> can be used directly to run jpilot-sync.
> 
> *If* I load the visor module and then hit the hotsync button
> /dev/pilot is created.  I can then manually run jpilot-sync.
> 
> I tried adding in a udev rule
> 
> KERNEL=="ttyUSB*", \ 
>     ATTRS{product}=="Palm Handheld*|Handspring *|palmOne Handheld", \
>     RUN="/sbin/su - moseley -c jpilot-sync"
> 
> Now that failed, so if I instead do:
> 
> 
>     RUN="/sbin/su - moseley -c 'sleep 2; jpilot-sync'"
> 
> then it works.  But, I also notice that *two* copies of jpilot-sync
> are started (seems the rule is run twice -- perhaps for the two USB*
> connections that it sets up).
> 
> Is it correct to use udev to run jpilot-sync?  Or do I need hotplug
> still?
> 
> I tried adding a /etc/hotplug/use/visor script but it doesn't get run. 
> IIRC, seems I need a mapping file that looks at vendor ID.
> 
> Can someone clear this up for me?

I'm using ubuntu gutsy (jpilot 0.99.9.10)

I am struggling with this same issue. When I hit the sync button on the 
pilot, udev makes these:

 > usbdev2.15_ep00
 > usbdev2.15_ep01
 > usbdev2.15_ep02
 > usbdev2.15_ep81
 > usbdev2.15_ep82

I have no idea which one to point the pilot at.

I don't see any responses in the mailing list, did you ever figure it out?

thanks,

Jonathan Murray




More information about the Jpilot mailing list