[jp] Building JPilot on SuSE 10.3 - Missing pilot-link Header Files

Tom tmst08 at gmail.com
Mon Jun 16 21:03:23 EDT 2008


On Monday 16 June 2008, David A. Desrosiers wrote:
> On Mon, 2008-06-16 at 12:02 -0700, Tom wrote:
> > I installed the libpisync-devel package. Is there another binary
> > which has the pilot-link headers? Or perhaps they're just not being
> > found by JPilot's configure script?
>
> Did you point them to the right location? That location would be the
> prefix where you installed pilot-link/include, in most cases. This
> means if you used --prefix=/opt/pilot-link, you would use
> --with-pilot-prefix=/opt/pilot-link to have J-Pilot's configure
> script look there for the pilot-link header files.
>
> Did you do that?
>
> > Also, running the pilot-link configure script --with-included-popt
> > resulted in the same error during make - missing popt.h.
>
> Did you do a 'make distclean' and remove autom4te.cache first?
> Building software is not generally done by people who haven't done it
> before. Every precaution is usually taken to make the errors useful
> and the output sane, but that may not always be the case. With over
> 300 separate Linux distributions and at least 10 different packaging
> systems, it gets difficult to catch them all.
>
> > But the pilot-xfer and other binaries I recognize are missing from
> > the build tree. There's a libpisock.la and a libpisync.la, though.
>
> As mentioned in a previous message, did you use --enable-conduits?
>
> Userland conduits (like pilot-xfer) are disabled by default, unless
> you specifically turn them on.
>
> > Something fundamental has changed, apparently. Might I have better
> > luck with pilot-link 0.12.2?
>
> I'd try using the latest stable release from the pilot-link.org
> website first, for testing, and if that works, try rolling back to
> the version supplied with your distribution.
>
Thanks. Doing a disclean and enabling conduits after installing the 
popt-devel binary resulted in a complete pilot-link build AFAICT.

Now I'm trying to build JPilot against the pilot-link 0.12.3 source 
tree, which has an include directory at the top level. I tried the 
following command:
./configure --with-pilot-prefix=/full/path/to/pilot-link-0.12.3
However, JPilot's configure still reports unable to find pilot-link 
headers.

Is there a binary I can install to make the pilot-link headers globally 
available on my system?

-Tom



More information about the Jpilot mailing list