[jp] Building JPilot on SuSE 10.3 - Missing pilot-link Header Files

Tom tmst08 at gmail.com
Mon Jun 16 15:02:06 EDT 2008


I installed the libpisync-devel package. Is there another binary which 
has the pilot-link headers? Or perhaps they're just not being found by 
JPilot's configure script?

Also, running the pilot-link configure script --with-included-popt 
resulted in the same error during make - missing popt.h.

However, after installing the popt-devel pkg, the pilot-link build 
proceeded without errors.

But the pilot-xfer and other binaries I recognize are missing from the 
build tree. There's a libpisock.la and a libpisync.la, though.

Something fundamental has changed, apparently. Might I have better luck 
with pilot-link 0.12.2?

-Tom

On Monday 16 June 2008, David A. Desrosiers wrote:
> On Mon, 2008-06-16 at 05:55 -0700, Tom wrote:
> > The pilot-link, libpisync version I have installed is 0.12.2-26
>
> You should be using the latest released version... 0.12.3, but 0.12.2
> should build fine for you, assuming you satisfy all pre-requisites.
>
>
> > Can someone point me in the right direction?
>
> snip [...]
>
> > contactsdb-test.c:28:18: error: popt.h: No such file or directory
>
> You lack the popt.h headers on your system.
>
> This means you need to either install the popt-devel package for your
> distribution or use --with-included-popt when building pilot-link to
> use the bundled copy I ship with each release.
>
>
>
> _______________________________________________
> Public archival of this list without permission is prohibited.
> http://lists.jpilot.org/mailman/listinfo/jpilot





More information about the Jpilot mailing list