[jp] can't sync

Carlo Graziani carlo at oddjob.uchicago.edu
Mon Jun 16 12:47:18 EDT 2008


Larry Grant wrote:
> On Sun, Jun 15, 2008 at 2:55 PM, Larry Grant
> <larry.grant at webpointtech.com> wrote:
>> I had been using jpilot flawlessly for quite a while with Ubuntu (up
>> to Hardy) and my Treo 600.  Now that I upgaded to a Centro, I haven't
>> been able to sync.
>>
>> So far, this is what I've done:
>>
>> First, I tried Restore From Handheld with the Centro.  It didn't
>> recognize the Centro.  Then I thought, maybe I need to build from
>> source to get the latest version of everything.  So I removed the
>> jpilot and pilot-link packages and installed both from source.  Still
>> no sync with the Centro.  Then I tried it with the Treo, and now it
>> won't even sync with that!  I saw online to try running from the
>> command line:
>>
>> pilot-xfer -p usb: --list
>>
>> and I got:
>>
>> pilot-xfer: command not found
>>
>> with advice to install pilot-link. I couldn't figure out why I don't
>> have pilot-xfer, if it's supposed to be part of pilot-link.  So then I
>> installed the pilot-link package to get it.  Now I'm getting:
>>
>>  Unable to bind to port: usb:
>>
>> from both the Treo and the Centro.
>>
>> I could really use some direction of what to do now.
> 
> I'd like to understand better some things about pilot-link, namely
> 
> - Do I need to make sure pilot-link is working before proceeding to
> troubleshoot jpilot?  Does jpilot actually use pilot-link?

Yes --- the libraries from pilot link are essential to jpilot.

> - Should I be using the latest pilot-linkpackage from Ubuntu or the
> latest pilot-linkfrom source (in case it matters, I am using the
> jpilot from source)?

My guess is that you went down a blind alley when you tried a from-source
install of jpilot.  It is more likely that your difficulties with the
centro have to do with the standard chronic afflictions that attend
udev configuration than with pilot-link/jpilot version.  Actually,
since jpilot uses libpisock from pilot-link to talk to devices, the
version of jpilot shouldn't matter at all.

> - Why did I not have the pilot-xfer program, after I installed
> pilot-link from source?

If the install was successful, then you did (and do) have pilot-xfer.
However, standard from-source installs generally put binaries in a different
location (/usr/local/bin) from the standard system-installed binaries
(generally /usr/bin).  If you do not add /usr/local/bin to your $PATH,
you won't see the binaries that you installed.  Try

/usr/local/bin/pilot-xfer -p usb: --list

and see if you still get "File not found".

> - Is there a specific pilot-xfer list i should consult?

No.  pilot-xfer is a standard part of pilot-link.

My advice is this:  locate and uninstall your from-source installations of
jpilot and pilot-link (I think you can "make uninstall" from the
installation directory, but I've never tried it), and re-install the Ubuntu
packages.  Then start working the problem from the udev end, which is where
99% of the "can't talk to my device" issues can be traced to.  David has a
nice HOWTO that covers talking to palm devices over USB, at
http://www.pilot-link.org/README.usb.

Cheers,

Carlo

-- 
Carlo Graziani                                 (773) 702-7973 (Voice)
Department of Astronomy and Astrophysics       (773) 702-6645 (FAX)
University of Chicago
5640 South Ellis Avenue        |  If the free market really allocates resources
Chicago, IL 60637              |  efficiently, why does LA have four times as
carlo at oddjob.uchicago.edu      |  many plastic surgeons as brain surgeons?



More information about the Jpilot mailing list