[jp] Building JPilot on SuSE 10.3 - Missing pilot-link Header Files

Tom tmst08 at gmail.com
Mon Jun 16 08:55:07 EDT 2008


Trying to build from source but configure reports that it can't find the 
pilot-link header files.

I am unable to find a pilot-link-devel, so I installed the 
libpisync, -devel stuff. Still no pilot-link header files. ?

Also, I tried to build pilot-link from source but got an error in one of 
the tests. Output included below. I was thinking I could at least test 
the new JPilot by linking it with a pilot-link I put into a 
subdirectory.

The pilot-link, libpisync version I have installed is 0.12.2-26

Can someone point me in the right direction?

-Tom

make[2]: Entering directory 
`/home/tom/Desktop/jpilot-1.6.0/pilot-link-0.12.3/tests'
if 
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I../include -I../include     -g2 -Wall -MT 
contactsdb-test.o -MD -MP -MF ".deps/contactsdb-test.Tpo" -c -o 
contactsdb-test.o contactsdb-test.c; \
        then 
mv -f ".deps/contactsdb-test.Tpo" ".deps/contactsdb-test.Po"; else 
rm -f ".deps/contactsdb-test.Tpo"; exit 1; fi
contactsdb-test.c:28:18: error: popt.h: No such file or directory
contactsdb-test.c: In function ‘main’:
contactsdb-test.c:352: warning: ‘pilot_connect’ is deprecated (declared 
at ../include/pi-header.h:31)
make[2]: *** [contactsdb-test.o] Error 1
make[2]: Leaving directory 
`/home/tom/Desktop/jpilot-1.6.0/pilot-link-0.12.3/tests'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory 
`/home/tom/Desktop/jpilot-1.6.0/pilot-link-0.12.3'
make: *** [all] Error 2



More information about the Jpilot mailing list