[jp] keyring sync problem with jpilot

Elizabeth Dodd edodd at billiau.net
Fri Mar 10 15:14:44 EST 2006


On Sat, 11 Mar 2006 03:32, P. Oscar Boykin wrote:
> Hello,
>
> I have a problem that I cannot seem to solve with the GNU Keyring plugin on
> jpilot.  I am using: jpilot version 0.99.9-cvs from debian unstable.  I am
> using it with a Tungsten T3.  I have used it for approximately 1.5 years
> and only recently has there been any problem.  I have only used this device
> with one computer running Debian GNU/Linux (unstable).
>
> The problem is the following:
>
> At some point in the somewhat recent past (say last 2 months) syncing GNU
> Keyring started giving the error:
>
> ====
> Fatal Alert
> DataMgr.c, Line: 6341,
> Invalid uniqueID passed
> [reset]
> =====
>
> I have tried a lot to diagnose the problem including:
>
> 1) deleting the Gtk-Keys.pdb on the pilot and reload a backup copy using
> pilot-xfer.
> 2) delete the Keyring.prc file and reinstalling a known good one.
> 3) doing a hard reset and restoring from an old backup (almost 1 year ago).
>
> None of this seems to solve the problem.  The backup restore will succeed,
> but the next sync fails.
>
> Then, I tried the following.  I noticed that the desktop has a few modified
> records (passwords that were changed after having been added to the
> database).
>
I had an account name change that I made on the Palm and synced with 
pilot-link (the newest test version, not CVS)
I had two test entries concatenated into one

> 1) If I delete the Keys-Gtkr.pc3 file (which I guess stores the changes to
> the database), then sync will succeed.
> 2) If I *ADD* records on the desktop or the palm, sync will succeed.
not here

> 3) If I *CHANGE* records on the palm, sync will succeed.
maybe, not tested

> 4) It seems that any change to an existing record will cause the sync to
> _fail_.

i hadn't tested this far

>
> This makes the plugin a major pain to use.  I can only add passwords from
> the desktop and I have to remember to change them using the palm.
>
> Is this a bug with the syncing code of jpilot?  Any suggestions?
>
> Best Regards,
> --
> P. Oscar Boykin                            http://boykin.acis.ufl.edu
> Assistant Professor, Department of Electrical and Computer Engineering
> University of Florida


I was trying to sort this out, but as I have udev issues and have to reboot 
the computer after a couple of syncs this is painful, then a power outage 
last night stopped all testing again.
The problem is different with pilot-link and with jpilot
I'm using a tungsten E.

Liz

-- 
Xerox never comes up with anything original.



More information about the Jpilot mailing list