[jp] Sync problems Palm Vx / ttyS0 / OpenSUSE 10.0

John C. Vernaleo john at netpurgatory.com
Fri Mar 3 11:13:11 EST 2006


Hi.  I'm not one of the most knowledgeable people here, but I think I'm 
one of the few still using a Palm Vx, so maybe I can help a bit.  I am 
a little surprissed since I've had far less trouble with the serial 
palm than with the newer usb palms.  I'm also using pilot-link 0.11.8, but 
using jpilot 0.99.7.

What kernel are you using?  And are you using udev?

What happens if you try

pilot-xfer -l

on the command line?  That should give a better idea if it is a connection 
issue or a jpilot thing.

John

On Fri, 3 Mar 2006, Carsten Pohle wrote:

> Hi all,
>
> I've already searched the list archive and read all the sync-prob threads, but
> found no solution to my problem yet.
>
> I'm trying to sync a Palm Vx via the serial port /dev/ttyS0 with JPilot 0.99.8
> and pilot-link 0.11.8. When I try to sync, initially everything looks fine,
> with consistend sync status displays in JPilot and on my Palm. However, after
> some seconds, the sync process seems to hang, and finally the Palm shows the
> "connection interrupted" error message. The JPilot log looks like this
> (sorry, it's in German):
>
> <jpilot-synclog>
> ****************************************
> Abgleich mit /dev/ttyS0
> Hot-Sync Knopf jetzt drücken
> ****************************************
> Benutzername -->"Carsten"
> BenutzerID -->28745
> Letzter SyncPC = 54861
> Dieser PC = 1456871139
> Langsamer Abgleich
> Synce DatebookDB
> Synce AddressDB
> Synce ToDoDB
> Synce MemoDB
> Synce Keys-Gtkr
> slow_sync_application: Unable to open file: Keys-Gtkr
> synctime: Palm OS version 40.104
> synctime: Setting the time on the pilot... Done
> ReadDBList returned = -1
> Fertig.
> </jpilot-synclog>
>
> Whether the sync stops at the AddressDB, DatebookDB, Keys-Gtkr or some other
> database is purely random from one trial to another. To mee, this seems like
> a timing problem on the serial port. I already tried different speed settings
> for the serial port, but had no success. Everything worked fine with the very
> same settings before I upgraded to OpenSUSE 10.0 with kernel 2.6.x. I can
> definetely tell that it's not a hardware issue, as syncing with Pilot Desktop
> under Win2K on the same machine works flawlessly.
>
> Thanks in advance for pieve of advice,
>
> Carsten
> _______________________________________________
> jpilot mailing list
> jpilot at jpilot.org
> http://www.jpilot.org/mailman/listinfo/jpilot
>


More information about the Jpilot mailing list