[jp] losing data on restore after a hard reset?

Vassilii Khachaturov vassilii at tarunz.org
Fri Oct 7 19:51:36 EDT 2005


I'm using the Debain-built jpilot 0.99.8-pre8.
I'm also syncing with the backup plugin conduit.

Today I have tried to re-sync after a hard reset
(preserving .jpilot in a backup just in case).

some 3 weeks ago I last did the
"sync the palm to your desktop and then do the backup"
operation; my last "sync the palm to your desktop" was
done 3 days ago. Since the last sync, I also made a couple
of changes to the address list on the PC.

I tried various ways to restore to the 3-days-ago state,
to no avail.

1) I tried to use
pilot-xfer -r .jpilot/Backup/LatestArchive
(which restores it to the 3 weeks ago state)
and then do a regular hotsync. This did not bring
the last 3-weeks changes in --- vice versa,
they disappeared from the desktop on the hotsync.

2) I tried to do "restore handheld" via the GUI --- same effect,
I guess it is doing the same operation internally.

3) I tried to do  pilot-xfer -r .jpilot/backup
and then do a regular hotsync. After the hotsync,
the memos get reset to the 3-week-ago version!
also, the PC-only change disappears.

I don't mind restoring everything except address+memo
to 3-week-ago state, but those 2 I need exactly as
they are in Jpilot before I commit the restore.

What should I do to accomplish this? Am I missing smth
obvious or is it a bug in jpilot?

Vassilii




More information about the Jpilot mailing list