[jp] Good fix for FC4 users -

Ryan Leduc leduc at control.toronto.edu
Wed Jul 13 00:30:28 EDT 2005


just in case people missed the e-mail below as its subject was:
" [jp] zire 72 and jpilot"  but this is a very nice fix to many of the FC4
woes people (myself included) have been having. 

It worked perfectly for my tre0 600.

I don't know if it addresses the read/write permission for serial device 
as I had already solved the problem by editing: 
/etc/udev/rules.d/50-udev.rules 

so the ttyUSB line reads:
  KERNEL=="ttyUSB*",              GROUP="uucp", MODE="0666"

You may want to look at the more elegant solution to this in e-mail by: 	
David A. Desrosiers  with subject "[jp] Fedora Core 4 (FC4) issues solved!"
(haven't tried myself).

However, the problem remained was that when jpilot did a fast sync,
changes from address book did not show up.

The solution below solved this.  It uses a set of RPMs from FC3
but relocates them to /opt/jpilot so they don't interfere with the normal 
ones.  Even gives a script so the libs get found!

One thing I found odd though is that I can no longer find the keyring 
menu item to access my encrypted data.

Note for x86_64:

I am running an AMD 64 system, so I originally grabbed the files below for 
x86_64.  I never tried to sync, but first tried accessing private files. 
It would NOT recognize my password.

I switched to the 386 rpms, and everything worked fine.

Seems there is a bug in jpilot for x86_64 when accessing passwords.

Ryan

On Tue, 12 Jul 2005, Andreas Micklei wrote:

> 
> I did this with some minor modifications:
> 
> - Kept the FC4 pilot-link package to not break dependencies. The FC3
>   pilot-link is relocated anyway.
> 
> - Relocated to /opt/jpilot because I wanted everything in one directory
>   and keep /opt clean for other application. Also used a newer openssl
>   from Fedora Core 3 updates (security!) and the i686 Version (speed):
> 
>   # rpm -ivh --force --relocate /usr=/opt/jpilot jpilot-0.99.7-2.i386.rpm
>   openssl-0.9.7a-42.1.i686.rpm pilot-link-0.11.8-8.i386.rpm
>   readline-4.3-13.i386.rpm
> 
> - Wrote a small start-script which sets LD_LIBRARY_PATH instead of
>   changing ld.so.conf.d, because I only want to use the old libraries
>   with jpilot, never with other applications:
> 
>   $ cat ~/bin/jpilot
>   #!/bin/sh
>   export LD_LIBRARY_PATH=/opt/jpilot/lib
>   /opt/jpilot/bin/jpilot
> 
> Now my Palm IIIc syncs perfectly via /dev/ttyS0 (a.k.a /dev/pilot) using
> jpilot. Everything installed in a matter of minutes without pulling CVS
> and building my own version. Thanks for the tip Hilkiah Lavinier!
> 
>    bye...
>          Andreas Micklei
> 
> 

-- 

__________________________________________________________________________
         Ryan Leduc         |    leduc at control.toronto.edu
                            |                                       
   Systems  Control Group   | Work like you don't need the money, Love
   University of Toronto    | like you've never been hurt, Dance like 
                            | nobody's watching.
                            |
                            |    http://www.control.toronto.edu/~leduc 
--------------------------------------------------------------------------





More information about the Jpilot mailing list