[jp] Fedora Core 4 (FC4) issues solved!

Andreas Micklei andreas.micklei at ivistar.de
Mon Jul 11 08:27:59 EDT 2005


Hiho,

On Mon, Jul 11, 2005 at 08:15:58AM -0400, David A. Desrosiers wrote:
> 
> > I can not get my Palm IIIc to sync with FC4 via serial.
> 
> > > > dlp_OpenConduit() failed
> > > > Sync canceled
> > > > Exiting with status SYNC_ERROR_OPEN_CONDUIT
> > > > Finished
> 
> > I did not try this yet, but pilot-xfer on it's own works perfectly, 
> > just jpilot fails since I upgraded from FC3 to FC4. So I don't think 
> > my Palm device is screwed up.
> 
> 	I'll reinstall FC4 on the test machine and see why I am unable 
> to reproduce these errors that everyone seems to be seeing. 
> 
> 	What *EXACT* version of J-Pilot are you using here? 

I first tried the version in Fedora-Extras.

I then pulled the version from CVS on Thursday and copied over some
files from the latest release (some NLS macros, some scripts) as someone
explained on this list.

> > I tried compiling the CVS version if jpilot as suggested on this 
> > list but using the pilot-link package from FC4 (since pilot-xfer 
> > works on the commandline). No success. I am going to try the FC3 
> > RPMs next. Thanks for the hint.
> 
> 	Don't install FC3 RPMs on FC4, that's a bad idea. Any time you 
> use --force when installing rpms, you totally screw your RPM package 
> database dependencies... and you might as well just reinstall from 
> scratch. If you have to use --force, something else is wrong. Fix that 
> problem first, and try again.

I don't want to force anything. Just uninstall the defunct RPMs and
install the older ones, maybe with relocation to /opt or somewhere as
explained on this list.

-- 
Andreas Micklei
IVISTAR Kommunikationssysteme AG
Ehrenbergstr. 19 / 10245 Berlin
http://www.ivistar.de



More information about the Jpilot mailing list