[jp] Keyring: Cannot transfer working keyfile to other JPilot or Palm

Karl Voit mail at Karl-Voit.at
Tue Jan 4 21:57:58 EST 2005


Hi folks!

What I wanted to do: I want to switch from ZSafe (a tool like GNU
Keyring that runs e.g. on a Sharp Zaurus PDA) to GNU
Keyring. Therefore, I did some copy&paste on a host "lisa" which runs
Debian sid and J-Pilot 0.99.8-pre6 with the according plugin for
Keyring.

Though I can not sync with my Palm m100 on this host, I copied the
JPilot-files to a host called "maggie" which is configured for
syncing. maggie runs also Debian sid but for PowerPC (on an iBook).

I already used this JPilot installation on maggie with Keyring two
years ago (Please remember below, when I write about the "old
password"). I updated everything to JPilot 0.99.8-pre6 and overwrote
the old keyfile:

First, lets try to copy ~/.jpilot from lisa to maggie:

J-Pilot means that the Username differs and that could lead to unknown
things. I sync anyway...

OK, sync worked so far (the m100 wrote that the device must be
resetted; which I did). After this, the new database was visible in
Keyring but every entry was doubled. The new password was not accepted
as valid. After entering the old password (ok, the password must be
stored elsewhere), I got the error message: 

,----[ Keyring message on m100 ]
| Error accessing key
| database: record
| underflow
| (Keys_UnpackRecord)
`----

And then, everything which is encrypted (everything except the name of
the entry) is scrumbled as if it is not decrypted anyway.

Then I wanted to change to the current password. Maybe this is the
problem. So I chose "define password" from the menu and then I entered
the old pw and then twice the new pw.

After that, Keyring tried to encrypt every entry with the new password
and so I got the error message above a LOT of times. Therefore I
guess, that Keyring is reencrypting every entry after changing the
password.

In the JPilot-plugin of Keyring, the entries are also scrubled as if
they were not decrypted.

Installing the file Keys-Gtkr.pc3 (with the normal Ctrl-I option)
failed with error message "Unable to sync file:
'/home/vk/Keys-Gtkr.pc3': file corrupted?" The file itself has the
same MD5-sum on lisa and maggie and JPilot on lisa can decrypt the
password. So the file itself cannot be corrupt.

Questions:

Why did the copy of the file Keys-Gtkr.pc3 did not work in my other
JPilot?

What do I have to do to make it work in JPilot and Keyring?

Thank you very much!

I want to get my current database fixed, before I have to retype the
whole thing again (approx. 150 entries).


PS: I tried to use gmane.org instead of this mailing list but I
noticed, that the list maintainer rejected this service :-(

-- 
Karl VOIT                                  http://www.Karl-Voit.at/howtos/#email



More information about the Jpilot mailing list