[jp] Sync problem

Michael Ash mash at econs.umass.edu
Tue Jun 22 14:55:44 EDT 2004


I am having a problem with syncing my new Zire 21 with
jpilot.  I used to have no trouble syncing my Handspring
Visor Platinum with jpilot, but the Visor is broken.

I have had no trouble syncing the Zire 21 on Windows XP or
connecting with pilot-xfer on linux using the USB cable.

After pressing the HotSync button on the Zire, I get the following:

****************************************
 Syncing on device /dev/pilot
 Press the HotSync button now
****************************************
pi_socket Invalid argument
Exiting with status (null)
Finished


I have compiled and installed J-Pilot version 0.99.7, and the jpilot desktop works.

Date compiled Jun 22 2004 14:13:54
Compiled with these options:
 Installed Path - /usr/local
 pilot-link version - 0.11.8
 USB support - yes
 Private record support - no
 Datebk support - yes
 Plugin support - yes
 Manana support - yes
 NLS support (foreign languages) - yes
 GTK2 support - no

I compiled and installed pilot-link 0.11.8.  I have tested
"pilot-xfer -l" and "pilot-xfer -t", and both connect to the
Zire and do what they are supposed to (list all files and
set the time on the Zire, respectively).  They work with
both with the default port and with the port specified,
e.g., "pilot-xfer -p /dev/pilot -l"

In jpilot, I have tried File->Preferences->Settings->SerialPort both blank and with /dev/pilot

I'd be grateful for advice and happy to supply more information.


Best regards,

Michael Ash, Assistant Professor
  of Economics and Public Policy
Department of Economics and CPPA
University of Massachusetts
Amherst, MA 01003
Tel 413-545-6329 Fax 413-545-2921
Email mash at econs.umass.edu
http://people.umass.edu/maash



More information about the Jpilot mailing list