[jp] Can't sync with Clie PEG-SJ22

Jonathan Murray jmurray at whoi.edu
Wed Oct 15 12:36:46 EDT 2003


jpilot-0.99-87
pilot-link-0.9.5-13
2.4.20-20.7
Redhat 7.3

When I try to run pilot-xfer I get the following error with either 
/dev/ttyUSB0 or /dev/ttyUSB1

pilot-xfer -p /dev/ttyUSB0 --install AddressDB.pdb
    Port: /dev/ttyUSB0

    Please press the HotSync button now...

It then hangs and times out and disconnects. My system is obviously 
seeing the device, anyone know what I could be missing.

ct 15 12:26:49 trilobite kernel: usbserial.c: Handspring Visor / Treo / 
Palm 4.0 / Clié 4.x converter detected
Oct 15 12:26:52 trilobite kernel: usb_control/bulk_msg: timeout
Oct 15 12:26:52 trilobite kernel: visor.c: visor_startup - error -110 
getting connection info
Oct 15 12:26:52 trilobite kernel: usbserial.c: Handspring Visor / Treo / 
Palm 4.0 / Clié 4.x converter now attached to ttyUSB0 (or usb/tts/0 for 
devfs)
Oct 15 12:26:52 trilobite kernel: usbserial.c: Handspring Visor / Treo / 
Palm 4.0 / Clié 4.x converter now attached to ttyUSB1 (or usb/tts/1 for 
devfs)
Oct 15 12:26:55 trilobite /etc/hotplug/usb.agent: Setup visor for USB 
product 54c/66/100
Oct 15 12:27:49 trilobite kernel: usb.c: USB disconnect on device 
00:1f.4-1 address 7
Oct 15 12:27:49 trilobite kernel: usbserial.c: Handspring Visor / Treo / 
Palm 4.0 / Clié 4.x converter now disconnected from ttyUSB0
Oct 15 12:27:49 trilobite kernel: usbserial.c: Handspring Visor / Treo / 
Palm 4.0 / Clié 4.x converter now disconnected from ttyUSB1

jpilot gives the following error again with either /dev/ttyUSB0 or 
/dev/ttyUSB1:

****************************************
  Syncing on device /dev/ttyUSB1
  Press the HotSync button now
****************************************
pi_bind Illegal seek
Check your serial port and settings
exiting with status -10
****************************************

Ideas appreciated,

thanks

Jonathan Murray





More information about the Jpilot mailing list