[jp] Re: Expenses plug-in SIGSEGV, gtk problem?

Raimondo Giammanco giamma at vki.ac.be
Wed Mar 26 03:36:54 EST 2003


Hello, 

	Yes, I compiled from plain sources. 

	I had the same problem with 0.99.4, compiled
	as well from sources. I did not try an RPM,
	waybe I could try on the Laptop with vanilla RedHat 8.0.

	On a side note, I am just now setting up
	a Gentoo system possibly with gtk2 (as far I
	understand, jpilot should have support for it); 
	as soon as I finish I will try jpilot there.

	It is a pity that the plugin does not work,
	because I like gnucash a lot,
	and it will be wonderful to interface 
	the expenses application of my palm with
	it..

	The other plugin, keyring, works fine instead.

			Raimondo Giammanco

> 
> Hmm, it looks like gtk crashing to me.  Thats not to say jpilot isn't 
> sending gtk bad pointers or something.  Did you build this from source?
> 
> Judd
> 
> Raimondo Giammanco wrote:
> > Hello, 
> > 	I am experiencing problems with the expenses
> > 	plug-in. I am sending this report to the
> > 	principal mailing-list, hoping not to 
> > 	bother anyone.
> > 
> > 	Jpilot is at 0.99.5, Expenses is at 0.99 (from
> > 	help jpilot).
> > 
> > 	It is compiled with sources on a redhat 7.0,
> > 	2.4.20 with gcc 3.2 and with the following 
> > 	output for rpm -qa | grep -i gtk
> > ####################################################
> > gtk-engines-thinice-1.0.4-ximian.1
> > gtk-themes-1.0.1-1.ximian.1
> > pygtk-libglade-0.6.9-3.ximian.5
> > libgtkhtml13-0.10.1-ximian.1
> > pygtk-0.6.9-3.ximian.5
> > gtk-gnutella-0.91.1-0
> > libgtkhtml16-0.13.0-ximian.1
> > libgtkhtml15-0.12.0-ximian.6
> > gtkhtml-1.0.4.99-snap.ximian.200208120601
> > rep-gtk-libglade-0.15-ximian.7
> > rep-gtk-0.15-ximian.7
> > gtk+-1.2.10-ximian.25
> > libgtkhtml17-0.14.0-ximian.2
> > libgtkhtml20-1.0.4.99-snap.ximian.200208120601
> > Gtk-Perl-0.7008-ximian.3
> > gtkhtml-devel-1.0.4.99-snap.ximian.200208120601
> > gtk+-devel-1.2.10-ximian.25
> > rep-gtk-gnome-0.15-ximian.7
> > gtk-engines-0.12-ximian.1
> > libgtkhtml19-0.16.1-ximian.1
> > #######################################################
> > Now, jpilot seems working fine, backup, sync etc.
> > with a palm m500 os 4.0; for the expenses application,
> > if there are no elements in the db, the expenses
> > plug-in works. As long as I enter an expense in the
> > palm and after I sync, the plug-in gives sigsegv.
> > 
> > gdb OUTPUT BEGIN
> > #######################################################
> > Program received signal SIGSEGV, Segmentation fault.
> > gtk_type_check_object_cast (type_object=0x6175675f, cast_type=43797)
> >     at gtktypeutils.c:624
> > 624	gtktypeutils.c: No such file or directory.
> > 	in gtktypeutils.c
> > #######################################################
> > gdb OUTPUT END
> > 
> > gdb BACK TRACE BEGIN
> > #######################################################
>
....

....

-- 

Raimondo Giammanco			  
	
	Ph.D. Candidate at EA Dept. of VKI 
	   72, Chaussée de Waterloo
	    1640 Rhode-Saint-Genèse	   
	            Belgique
	      Tel (32) 2-359.96.11 
	      http://www.vki.ac.be
	     





More information about the Jpilot mailing list