[jp] Sync times out during ToDoDB

Brad Rodriguez bj at zetetics.com
Mon Mar 17 09:00:17 EST 2003


Apologies if this has been addressed before, but I didn't see a similar problem 
in the archives.  My problem is this: when I do a Sync operation, Jpilot gets as 
far as "Syncing ToDoDB" and then progress stops.  Eventually the Palm (m105) 
times out ("the connection between your handheld computer and the desktop was 
lost").  The Jpilot program does not lock up or crash -- it's still running, and 
I can view everything and even start another Sync (which doesn't work any better 
than the first one).  Comparing the Palm to Jpilot, it looks like the ToDo items 
from the Palm were loaded correctly onto the desktop.  But I've tried adding a 
To-Do item on Jpilot, and it didn't get transferred to the Palm.

It stops at the same point when I do Backup.  If I turn off the "sync ToDo" 
conduit in Preferences, Sync works fine and it proceeds to "Fetching Saved 
Preferences" and "Finished"; and Backup also works.  If I turn on *only* the 
ToDo conduit, it still times out as before.  I can do a full backup with 
"pilot-xfer -b" with no problem.

When I first started using Jpilot I had this problem intermittently, and I 
thought I had fixed it by reducing the baud rate to 9600.  That worked fine for 
a few weeks, but may have been coincidental since I was changing several things. 
  Now, however, the problem has returned, and won't go away.

I'm using Red Hat 8.0 on a Pentium II 400 MHz, and a Palm m105.  I'm using 
pilot-link 0.11.3.  I encountered this with Jpilot 0.99.4 but the upgrade to 
0.99.5 hasn't helped.  I'm not using any Jpilot plugins; I'm syncing only 
datebook, address, todo, and memo.

Is this a known problem?  Is there a fix?
Regards,
Brad Rodriguez



More information about the Jpilot mailing list