[jp] Network sync?

Atul Chitnis achitnis at exocore.com
Sun Jun 1 16:51:01 EDT 2003


On Sun, 1 Jun 2003, Nicholas Piper wrote:

> That hostname doesn't resolve to that IP for me (if it does in your
> DNS, that's ok, so long as your palm is using your DNS).

Used etherreal, watched ppp0, saw the desperate attempts at resolving the 
name...

(Open (human) palm meets forehead, slapping sound wakes dog)

It was the DNS - I had totally forgotten that these private IP addresses
used for the PC to Palm ppp connection weren't registered in the LAN's
DNS, and since I was NATing out, the rest of the LAN never saw them,
either.

Rather than go fiddle with production servers and DNS setups (admin has 
teeth), I decided to try it giving *only* the IP address in the Primary PC 
setup on the palm, and no name (i.e. I removed wookie.exocore.com, leaving 
Primary PC name blank).

Tweedledee! Worked first shot! Jpilot and pilot-link rock!

Only caveat - I find that I have to hit jpilot's sync button *before* I 
start the hotsync on the palm. Kind of confusing for a guy who has trained 
himself to hit the jpilot sync button only *after* hitting the hotsync 
button on the cradle ;-)

> Also, jpilot could be listening on the wrong interface. You can do
> net:192.168.99.1 IIRC to it listen on a particular one.

Without the name specified, worked both with and without specifying IP
address with net:, but good point for another reason - specifying the
interface will prevent some random Palm on the LAN from syncing with my
jpilot ;-)

> It's not really a performance improvement, it's just a one-liner hack
> to 'fix' this problem:
>  http://marc.theaimsgroup.com/?l=linux-ppp&m=105389336517645&w=2

Hey cool! If your hack fixes that issue, it would certainly make life 
simpler, especially people trying to script something, the way I am trying 
to do right now. 

I have been struggling with a way to get hotplug to kick off a ppp connect
if it sees a Palm come online on my USB port to get around the "Failed to
open /dev/ttyUSB1: No such device" issue. This was what caused me to go
look for a network hotsync solution to begin with (since the port would
never be free for a normal hotsync if pppd is running), which lead to this 
thread.

Would appreciate getting the patch and your network-sync stub program.

(You wouldn't by any chance also have a stub to kick off a network
connection one-click, to avoid the prefs>network>connect routine, would
you? ;-) )

Many many thanks!

Atul

-- 
-------------------------------------------
Atul Chitnis       | achitnis at exocore.com
Exocore Consulting | http://www.exocore.com
Bangalore, India   | +91 (80) 344-0397
-------------------------------------------




More information about the Jpilot mailing list